686 Utilities is experiencing degraded performance across all services.
Resolved
Dec 20 at 11:09pm GMT
The issue has been resolved.
As usual, to be transparent, here's what happened:
LCPDFR.com sustained a large attack on their website which resulted in their system entering a protected state. Due to the usage that 686 Utilities makes with LCPDFR.com, we were inadvertently caught in the blocks made as a result of the attack.
We'll continue to monitor the situation and learn how best to mitigate future circumstances like these.
Affected services
Discord Bot
Updated
Dec 20 at 06:00pm GMT
We are in contact with LCPDFR.com Site Management to resolve this.
Affected services
Discord Bot
Updated
Dec 15 at 11:54pm GMT
686 Utilities is now online & Automatic Log Reading has been re-enabled, however certain features remain disabled.
I'd like to apologise for recent instability.
To be completely transparent about what happened, 686 Utilities is currently only receiving intermittent responses from LCPDFR.com.
As a result, Automatic Log Reading - which makes use of connections to the website - became very slow, and was unable to process any requests. We've put in place temporary measures to get this back online, and the silver lining is now Automatic Log Reading takes less than 10 seconds! After discovering this optimisation, we'll be making sure it remains even when normal functionality resumes.
However, due to the issues connecting with LCPDFR.com, we have temporarily disabled Plugin Updates, Automatic Announcements & Manual Plugin Check.
These all involve connecting to LCPDFR.com. A domino effect of these connection problems was that 686 Utilities did not continue through with checking the ScriptHookV update status, and did not detect the update. It was very unlucky timing, and I'm disappointed that we weren't able to announce the update.
I have reached out to LCPDFR.com staff to resolve this as soon as we can. In the meantime, I would appreciate your patience until we can get this ironed out.
Affected services
Discord Bot
Created
Dec 15 at 10:56pm GMT
We've had to take mitigating action & remotely disable all areas - except core moderation functionality - of 686 Utilities while we investigate.
This has caused the ScriptHookV announcement to fail. Please accept our apologies.
Affected services
Discord Bot